Friends of the Professional Car Society - Official Website of the Professional Car Society, Inc.Friends of the Professional Car Society - Official Website of the Professional Car Society, Inc.



Go Back   Friends of the Professional Car Society - Official Website of the Professional Car Society, Inc. > Professional Car Discussion > Technical Discussion Forum

Technical Discussion Forum For the discussion of technical questions about Professional Cars and their repair and maintenance. Posting in this forum is limited to PCS Members and / or Site Supporters. We encourage all website users to become members of the Professional Car Society and / or become Site Supporter.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-21-2009, 08:42 AM
Richard Vyse Richard Vyse is online now
Website Member
 
Join Date: Mar 2009
Location: New Smyrna Beach FL 32168
Posts: 5,099
Thanks: 6,047
Thanked 6,925 Times in 2,282 Posts
Groans: 2
Groaned at 13 Times in 5 Posts
Default Slight clicking in my motor...

The Criterion has a slight clicking in the left bank. It is less noticable after it is warmed up but still there. I have not changed the oil yet but once that is done and if it continues, are there any remedies available other than tearing the motor apart.
Reply With Quote
  #2  
Old 10-21-2009, 08:50 AM
Paul Steinberg Paul Steinberg is offline
PCS Past President / Senior Website Administrator
 
Join Date: Mar 2009
Location: Woodstock CT 06281
Posts: 6,164
Thanks: 6,324
Thanked 11,377 Times in 3,713 Posts
Groans: 0
Groaned at 9 Times in 9 Posts
Default

Before you change the oil, put a quart of engine flush such as Rislone into the engine and drive it for a while. Then if it continues to click after you change the oil, add a pint of Sea Foam to the oil and just drive it as normal till the next oil change. If it doesn't clear up by then, it might be time for exploratory surgery.
__________________
"When a man opens a door for his wife, it's either a new car or a new wife."
Reply With Quote
  #3  
Old 10-21-2009, 08:51 AM
Richard Vyse Richard Vyse is online now
Website Member
 
Join Date: Mar 2009
Location: New Smyrna Beach FL 32168
Posts: 5,099
Thanks: 6,047
Thanked 6,925 Times in 2,282 Posts
Groans: 2
Groaned at 13 Times in 5 Posts
Default

Words of encouragement! Tks
Reply With Quote
  #4  
Old 10-21-2009, 07:55 PM
Mike Stevens Mike Stevens is offline
PCS Member
 
Join Date: Mar 2009
Location: Springfield OH 45505-3159
Posts: 1,526
Thanks: 1,568
Thanked 1,385 Times in 610 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Smile clicking sound

I had a Ford years ago that had engine noise issues. Turned up the radio and viola! problem solved.
Really I put a pint of auto trans fluid in the oil at oil change time. After about 600 miles I imagined the noise was dimishing. By the time I had gone 1000 miles it was not my imagination...the noise WAS gone. The trans fluid had more detergent I have been told. That engine went many, many more miles before being changed out.
Mike
Reply With Quote
The Following User Says Thank You to Mike Stevens For This Useful Post:
Richard Vyse (10-22-2009)
  #5  
Old 10-28-2009, 05:19 PM
Brendan Martin Brendan Martin is offline
PCS Member
 
Join Date: Mar 2009
Location: Tiverton RI 02878
Posts: 1,471
Thanks: 1,853
Thanked 1,834 Times in 729 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Default

Richard when I got my 63 it had a slight tap on the right side. Turns out it was a bad rocker arm. We changed it out, as well as some other minor work and now it runs quiet and smooth.
Reply With Quote
  #6  
Old 10-29-2009, 09:39 AM
Richard Vyse Richard Vyse is online now
Website Member
 
Join Date: Mar 2009
Location: New Smyrna Beach FL 32168
Posts: 5,099
Thanks: 6,047
Thanked 6,925 Times in 2,282 Posts
Groans: 2
Groaned at 13 Times in 5 Posts
Default

Quote:
Originally Posted by Brendan Martin View Post
Richard when I got my 63 it had a slight tap on the right side. Turns out it was a bad rocker arm. We changed it out, as well as some other minor work and now it runs quiet and smooth.
Still clicking but only driven 125 miles. Still have fingers crossed.
Reply With Quote
  #7  
Old 10-29-2009, 10:10 AM
Brendan Martin Brendan Martin is offline
PCS Member
 
Join Date: Mar 2009
Location: Tiverton RI 02878
Posts: 1,471
Thanks: 1,853
Thanked 1,834 Times in 729 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Default

Good luck hopefully it's an easy fix.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front End Clicking Noise Paul Steinberg Technical Discussion Forum 2 04-02-2012 01:02 PM


All times are GMT -4. The time now is 07:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2009 - 2018 Friends of the Professional Car Society